To view uptime history for your instance of Canvas, click here.

Users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Canvas continues to function normally, and we are not seeing any new instances of slowness occurring for users. We appreciate your patience with any trouble you may have experienced with this today.
Posted Mar 27, 2017 - 18:05 MDT
Monitoring
A small percentage of Canvas users experienced slowness or timeout errors while attempting to access Canvas between 3:45 and 4:20 PM Mountain Time. Our Operations team has addressed the issue, and we are now seeing normal page load times. We will continue to monitor the situation to ensure continued functionality. We apologize for any issues this may have caused.
Posted Mar 27, 2017 - 16:47 MDT