To view uptime history for your instance of Canvas, click here.

Users at some schools experiencing slowness and scattered error messages in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has fixed the problem causing slowness for some users over the last 5-10 minutes. Performance should be normal for all users again. We apologize for the trouble!
Posted Aug 26, 2015 - 12:29 MDT
Identified
Users at some Canvas schools are experiencing slowness and scattered error messages in Canvas currently. Our DevOps team has identified the source of the problem (an infrastructure element that balances load amongst database servers) and is addressing the problem. We'll provide an update in 15 minutes or less.
Posted Aug 26, 2015 - 12:25 MDT