To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has verified that all servers are functioning normally once again.  Users should no longer be experiencing slowness and timeout errors when accessing Canvas.  Thank you for your patience as we investigated the issue.
Posted Dec 21, 2016 - 02:42 MST
Monitoring
Our DevOps team identified an issue affecting one of our servers, which was causing the slowness and timeouts seen by some of your users. They have resolved this issue and are continuing to monitor activity to ensure all is working well again. We'll provide another update within the next 15 minutes.
Posted Dec 21, 2016 - 02:28 MST
Investigating
We are currently looking into degraded performance for a very small group of users, who are seeing slowness and intermittent page errors. We will provide an update in 15 minutes or less.
Posted Dec 21, 2016 - 02:04 MST