To view uptime history for your instance of Canvas, click here.

Users at some schools experiencing slowness and scattered error messages in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has fixed the problem causing slowness for some users over the lasted for 12 minutes. Performance should be normal for all users again. We apologize for the trouble!
Posted Aug 28, 2015 - 09:15 MDT
Investigating
Users at some Canvas schools are experiencing slowness and scattered error messages in Canvas currently. Our DevOps team is investigating the issue. We'll provide an update in 15 minutes or less.
Posted Aug 28, 2015 - 09:00 MDT