To view uptime history for your instance of Canvas, click here.

Intermittent Slowness and Page Errors
Incident Report for Instructure
Resolved
Our DevOps team has resolved this issue. Performance has returned to normal and Canvas should be available again for all users. Again, we apologize for any inconvenience this may have caused and appreciate your patience regarding this.
Posted Sep 19, 2017 - 19:47 MDT
Monitoring
It looks like the majority of affected users are back to acceptable performance levels. There's still a small amount of users that might be affected as we continue to roll out mitigation factors. We'll post another update once this is fully implemented. Thank you for your patience.
Posted Sep 19, 2017 - 19:27 MDT
Identified
Our DevOps team have found the potential source of the slowness, and page errors. We are currently implementing a mitigation plan, and we'll post an update once this is complete. Thank you for your continued patience.
Posted Sep 19, 2017 - 19:19 MDT
Update
The number of affected users has expanded, as this issue is more widespread than previously thought. Our DevOps team are continuing to work on this problem as fast as possible. We sincerely apologize for this situation and appreciate your patience.
Posted Sep 19, 2017 - 19:05 MDT
Investigating
Canvas users in the U.S. may be experiencing scattered intermittent slowness and timeout errors. These issues are happening for a small percentage of Canvas users at a few accounts. Our DevOps team has identified the cause and is working on a fix. We'll post an update here as soon as it is available.
Posted Sep 19, 2017 - 18:49 MDT