Error stating "Cannot Lease Connection". June 22nd 7:43 PM MST
Incident Report for Canvas
Resolved
This incident has been resolved. We will continue to watch and monitor for the issue.
Posted 6 months ago. Jun 22, 2017 - 20:33 MDT
Investigating
Some users have received an error in Canvas stating "Cannot Lease Connection". Our Developers are currently looking into the issue.
Posted 6 months ago. Jun 22, 2017 - 20:14 MDT