To view uptime history for your instance of Canvas, click here.

Brief ARC outage 7:50PM MST
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 10, 2017 - 20:02 MDT
Investigating
On July 10th at 7:50 PM some users were briefly experiencing issues with videos using the ARC app. Our ARC developers quickly resolved the issue and we are now monitoring the issue to ensure it is resolved.
Posted Jul 10, 2017 - 20:01 MDT