To view uptime history for your instance of Canvas, click here.

Some Canvas users experiencing slowness and page errors
Incident Report for Instructure
Resolved
Our DevOps team has restored normal performance for the institutions that were experiencing slowness this morning. We will provide an incident report to admins at affected schools by email by the end of the day tomorrow.
Posted Sep 02, 2015 - 08:57 MDT
Update
Our DevOps team is continuing to investigate slowness and elevated page error rates affecting a small percentage of Canvas accounts. We apologize for the issue; we'll post an update as more information becomes available.
Posted Sep 02, 2015 - 08:56 MDT
Investigating
Our DevOps team is investigating slowness and elevated page error rates affecting a small percentage of Canvas accounts right now. We apologize for the issue; we'll post an update in 15 minutes.
Posted Sep 02, 2015 - 08:22 MDT