Some Canvas Components are Experiencing Interruptions of Service
Incident Report for Canvas
Resolved
After monitoring the situation for some time, we are confident that the intermittent problems that were occurring earlier have been resolved. We are truly sorry for any inconvenience these interruptions may have caused, and greatly appreciate your patience and understanding.
Posted 5 months ago. Mar 13, 2017 - 11:58 MDT
Monitoring
Our remediation process has been implemented and a lot of Canvas processes appear to be working correctly again. We are continuing to monitor this situation though, to ensure there's no lingering effects. We will post another update once we are confident that there are no longer any issues.

We sincerely appreciate your patience.
Posted 5 months ago. Mar 13, 2017 - 10:30 MDT
Update
The restoration process is taking a bit longer than expected. Our DevOps team now thinks that it could be another 15-25 minutes. We will post updates as they become available, as well as when the remediation plan has been completed. Thank you for your continued patience
Posted 5 months ago. Mar 13, 2017 - 09:59 MDT
Update
We are working on a remediation plan to get Canvas services back to normal. Our DevOps team has informed us that the results of the plan may not be apparent for 30 minutes, but have started that process immediately. We will post an update once we have further information about the remediation process.
Posted 5 months ago. Mar 13, 2017 - 09:35 MDT
Update
Canvas DevOps team is still investigating what might be causing service interruptions for some Canvas users. It appears to be affecting components that have interaction with external services such as Authentication servers, Turnitin, and Crocodoc.

We'll post an update again shortly, thank you so much for your patience.
Posted 5 months ago. Mar 13, 2017 - 09:23 MDT
Update
Our engineers are continuing to troubleshoot the intermittent issues where users cannot login to Canvas nor view certain documents through Speedgrader. Another component that's being affected by this situation is media uploads are also sporadically experiencing a time out error message.

We will continue to post new updates every 15 minutes for this situation. We appreciate your patience.
Posted 5 months ago. Mar 13, 2017 - 09:04 MDT
Update
We've become aware that certain tools within Canvas are also currently inaccessible. This includes the Speedgrader function which is returning an error message for some instructors. This appears to be related to the same situation our engineers our currently investigating so we'll continue to post updates as they become available.
Posted 5 months ago. Mar 13, 2017 - 08:37 MDT
Investigating
Our Operations team is currently investigating reports of external authentications systems (CAS, LDAP, SAML) not processing successfully. We'll update soon with more details and thank you for your patience at this time.
Posted 5 months ago. Mar 13, 2017 - 08:25 MDT