To view uptime history for your instance of Canvas, click here.

Testing environment "Beta" non-accessable
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 21, 2015 - 03:45 MDT
Identified
We have identified the cause of the beta environment not being accessible for our users. Our engineers are applying a fix that will get the beta environment back online. We apologize for the inconvenience this may have caused for you and some of your users.
Posted Jul 20, 2015 - 14:30 MDT