To view uptime history for your instance of Canvas, click here.

A small number of users are receiving 503 errors
Incident Report for Instructure
Resolved
The error has been corrected and normal functionality has returned to all users.
Posted Feb 06, 2017 - 03:56 MST
Identified
Some users are seeing errors causing blank screens, our ops team is investigating.
Posted Feb 06, 2017 - 03:50 MST