To view uptime history for your instance of Canvas, click here.

Users at some Canvas institutions experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Canvas performance is back to normal for the affected Canvas sites. Please submit a request to Canvas Support if you notice any more slowness issues.
Posted Apr 30, 2015 - 19:52 MDT
Investigating
Some Canvas users are currently running into slowness within the application. This is resulting in slow page loads, and sometimes timeout errors. Our Operations team is looking into this. We apologize for any trouble.
Posted Apr 30, 2015 - 19:37 MDT