To view uptime history for your instance of Canvas, click here.

"All circuits busy" message when calling Support
Incident Report for Instructure
Resolved
The phone system has been fixed and is functioning properly again. We apologize for the inconvenience!
Posted Oct 04, 2016 - 09:37 MDT
Identified
Our phone provider is having an issue with the underlying carrier. They are in an “all hands on deck” mode to get it fixed.
Posted Oct 04, 2016 - 09:09 MDT
Investigating
Callers are getting an "All circuits busy" message when calling Support and aren't able to get through. We have contacted the phone provider and working on getting this fixed. In the meantime, please contact us either by the chat link in your Canvas site's help menu, or send us an email and we will be happy to help!
Posted Oct 04, 2016 - 08:53 MDT