To view uptime history for your instance of Canvas, click here.

Some users experienced slowness in Canvas
Incident Report for Instructure
Resolved
At about 8:44am this morning, our monitoring detected unexpectedly high load on infrastructure elements that serve some Canvas accounts. This resulted in slowness and some error messages for some users over the next 43 minutes as our DevOps team shifted load and added resource. At about 9:25am, load and resource conditions had changed to a point where your users experienced normal performance again. We sincerely apologize for the trouble this incident caused for you and your users.
Posted Jan 19, 2016 - 10:40 MST
Monitoring
Our Devops team has performed a fixed to the issue which has reflected some performance improvements inside Canvas. Some users should now be able to access Canvas. The entire issue is not resolved. We will provide and update once the fix has completed running.
Posted Jan 19, 2016 - 10:00 MST
Update
Our DevOps teams is still under investigation on the cause of the issue. We will provide another update in 15 minutes.
Posted Jan 19, 2016 - 09:27 MST
Investigating
A small amount of users may experience slowness in Canvas. Our DevOps team is investigating the cause of this behavior. We'll post an update in 15 minutes.
Posted Jan 19, 2016 - 09:09 MST