To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness currently
Incident Report for Instructure
Resolved
Our DevOps team added resources to one part of the Canvas infrastructure; this has returned performance to normal for users who experienced a couple of minutes of slowness. We apologize for the trouble!
Posted Nov 05, 2015 - 08:26 MST
Investigating
Our DevOps team is investigating slow performance affecting some Canvas users currently. More detailed update in a few minutes.
Posted Nov 05, 2015 - 08:18 MST