To view uptime history for your instance of Canvas, click here.

Crocodoc document rendering failing intermittently for some users
Incident Report for Instructure
Resolved
We've not seen additional reports of Crocodoc rendering problems in Speedgrader since yesterday evening. We're going to connect with our partners at Croc again this morning and ensure that we understand what happened yesterday and can expect solid performance from this point on. We will close this incident and open another in the event new reports of the problem come in.
Posted Dec 22, 2014 - 08:06 MST
Update
We continue to work on the sporadic document-not-rendering-in-Crocodoc / Speedgrader problem. We believe the issue lies on the Croc side and are standing by for assistance from our partners there. We will provide an update in two hours or when we have new info to provide, whichever comes first.
Posted Dec 21, 2014 - 15:22 MST
Update
We're still working to determine the root cause of this issue. We believe it to be on the Box/Croc side, as we're also seeing sporadic, identical failures when testing directly against the "try it" tool on the Croc web site. But we're not positive yet and we will continue to investigate. We apologize for the continuing sporadic issues with document rendering that some of your users are seeing. We'll post another update in an hour--sooner, if we determine the root cause.
Posted Dec 21, 2014 - 12:29 MST
Update
We continue to research this problem with our partners at Croc. We'll post another update in 30 or 45 minutes.
Posted Dec 21, 2014 - 11:35 MST
Investigating
Some Canvas users are seeing error messages when trying to view documents in Speedgrader and elsewhere in Canvas where Crocodoc is the rendering engine responsible for serving the request. We're working with our partners at Croc to investigate. In the meanwhile, users can download documents to view them. We'll provide an update in 30 minutes.
Posted Dec 21, 2014 - 10:48 MST