To view uptime history for your instance of Canvas, click here.

Slowness/Outage for some users
Incident Report for Instructure
Resolved
For now, the system performance issues have subsided and Our DevOps team will continue to monitor system performance.
Posted Jun 08, 2016 - 18:37 MDT
Monitoring
We're seeing an increase in users affected by this recent system performance issue. Our DevOps team is continuing to work on a resolution; we'll provide an update within the next fifteen minutes.
Posted Jun 08, 2016 - 18:21 MDT
Investigating
Some users at your institution are currently seeing slowness and possible timeout errors (white pages) in Canvas. Our DevOps team is aware of the issue and are currently working on a resolution; we'll provide an update within the next fifteen minutes.
Posted Jun 08, 2016 - 18:03 MDT