To view uptime history for your instance of Canvas, click here.

Content Picker Loading issue
Incident Report for Instructure
Resolved
Our DevOps team has implemented a solution to keep the "Loading failed" message from showing in the right-hand content-picker menu on "Edit" pages in Canvas (and anywhere else the rich content editor is used). Service was restored at about 4:03 pm MT.
Posted Aug 22, 2016 - 16:10 MDT
Monitoring
Over the last 20 minutes, some users have seen an issue causing the content-picker to show a "Loading failed; no results" message when trying to add files to a page, module, or other object in Canvas. Our DevOps team is addressing this problem, and users should stop seeing this message shortly. We apologize for the trouble!
Posted Aug 22, 2016 - 15:55 MDT