To view uptime history for your instance of Canvas, click here.

Users at some Canvas Institutions experiencing slowness
Incident Report for Instructure
Resolved
Our DevOps team was able to locate the issue and have applied a fix. The Canvas application appears to be running normally once again. You should no longer be seeing extreme slowness or timeout errors when attempting to access the site. Please let us know if you continue to have any trouble.
Posted Jun 27, 2015 - 14:55 MDT
Identified
Users at a few institutions maybe be currently experiencing slowness when accessing Canvas. This is resulting in slow page loads, and sometimes timeout errors. Our Operations team is looking into this. We apologize for any trouble.
Posted Jun 27, 2015 - 14:39 MDT