To view uptime history for your instance of Canvas, click here.

Users at some Canvas institutions experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Canvas performance is back to normal for the small group of institutions that were affected.
Posted Apr 15, 2015 - 17:42 MDT
Monitoring
Canvas performance for institutions affected by this issue has returned to normal. Our DevOps team manually added extra resources to improve performance for now while they continue to research the root cause.
Posted Apr 15, 2015 - 16:41 MDT
Investigating
Users at a small group of Canvas institutions are currently experiencing slowness in the application. Our DevOps team is looking into this and we'll provide an update in about 15 minutes. We apologize for the trouble!
Posted Apr 15, 2015 - 16:29 MDT