To view uptime history for your instance of Canvas, click here.

Canvas Support ticketing system not available to field admins currently
Incident Report for Instructure
Resolved
The Canvas Support ticketing system Field Admin Interface is back up and working as normal. Sorry for the five-minute issue there, admins! We'll keep an extra-close eye on it this morning to make sure it continues to work as it should.
Posted Feb 01, 2016 - 10:27 MST
Investigating
The Canvas Support ticketing system's field admin interface (cases.canvaslms.com) is not available to field admins currently. We're working with Salesforce to determine what the problem might be and will post an update in 15 minutes. We apologize for the hassle, field admin friends!
Posted Feb 01, 2016 - 10:21 MST