To view uptime history for your instance of Canvas, click here.

Users at some institutions unable to access or use Canvas currently
Incident Report for Instructure
Resolved
Our Engineering team has completed the roll out of enhanced timeout protection for the Google Drive service. This allows Canvas to quickly terminate requests to the Google Drive service when it is not responding. While we are still waiting for Google to fully resolve the problem and return Drive to a working state, we do not anticipate any further impact for our Canvas users.
Posted Oct 09, 2015 - 14:42 MDT
Update
Our DevOps team will soon deploy a fix that should mitigate the effect of the continuing Google Drive problems on Canvas performance. Users will see improved performance shortly.
Posted Oct 09, 2015 - 14:26 MDT
Update
The slow Canvas performance that some users are experiencing is related to an ongoing outage with the Google Drive external service. We are in the process of deploying a fix that will mitigate the effect of this downtime. Google is providing status updates here (https://www.google.com/appsstatus#hl=en&v=issue&sid=4&iid=af2a5bd91fb838a393f4d377033142dd) for users who are interested in following their progress.
Posted Oct 09, 2015 - 13:56 MDT
Monitoring
Our DevOps team has developed a fix for the issue causing slowness for some Canvas users currently. We'll get it deployed very shortly. We'll provide another update in 15 minutes.
Posted Oct 09, 2015 - 13:38 MDT
Update
Our DevOps team continues to work on a solution to the slowness and error messages that users at a few institutions are seeing in Canvas currently. We'll provide another update in 15 minutes.
Posted Oct 09, 2015 - 13:12 MDT
Investigating
Users at a few institutions are unable to access Canvas currently. Our DevOps team is working on a solution, and we will provide an update in 15 minutes or less. We apologize for the trouble.
Posted Oct 09, 2015 - 12:49 MDT