To view uptime history for your instance of Canvas, click here.

A small percentage of users experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Our operations team has resolved the issue and performance has returned to normal. We apologize for any inconvenience this has caused.
Posted Oct 13, 2016 - 17:43 MDT
Monitoring
Our operations team has identified the issue and continues to take steps to improve performance. We'll provide another update soon.
Posted Oct 13, 2016 - 17:10 MDT
Investigating
Some users may be experiencing slowness and timeout errors in Canvas. Our operations team is aware of the issue and are currently working on a resolution. We'll provide an update within the next fifteen minutes or less.
Posted Oct 13, 2016 - 16:47 MDT