To view uptime history for your instance of Canvas, click here.

Users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Our engineers have resolved the issue and server performance is now returned to normal status. We apologize for any inconvenience this has caused.
Posted Jan 03, 2017 - 06:20 MST
Investigating
We are currently looking into degraded performance for a small group of users, who are seeing slowness and intermittent 503 page errors. Our engineers are aware of the issue and are working towards a solution. We will provide another update shortly.
Posted Jan 03, 2017 - 06:07 MST