To view uptime history for your instance of Canvas, click here.

Errors when accessing Canvas
Incident Report for Instructure
Resolved
All access to Canvas has been restored at this time.
Posted Oct 03, 2016 - 09:47 MDT
Identified
A small percentage of users are seeing errors when trying to access Canvas. Our Devops team has identified the cause and is rolling out a fix.
Posted Oct 03, 2016 - 09:20 MDT