To view uptime history for your instance of Canvas, click here.

Canvas Jobs are experiencing higher than normal load times
Incident Report for Instructure
Resolved
Our queues for job requests in Canvas are back to normal levels again. We appreciate your patience as we worked through the large number of job requests this evening, and apologize for any trouble caused by the additional wait times.
Posted Dec 11, 2017 - 18:36 MST
Investigating
Some institutions may be experiencing a second occurrence of long job processing times. Canvas processes that may be affected include SIS imports, Gradebook exports, Course migration, and Canvas notifications. We appreciate your patience as we continue to work through the large number of job requests, and apologize for any trouble caused by the additional wait times.
Posted Dec 11, 2017 - 17:44 MST