To view uptime history for your instance of Canvas, click here.

A small percentage of Canvas users in the US are seeing slow load times in Canvas.
Incident Report for Instructure
Resolved
A small percentage of Canvas users in the US were seeing slow load times in Canvas between 07:17 and 07:41 MT. Our DevOps team has ensured the site is available and running normally now. We apologize for any trouble you've experienced.
Posted Oct 09, 2017 - 07:56 MDT
Monitoring
A small percentage of Canvas users in the US are seeing slow load times in Canvas. Our. A fix has been implemented and we are monitoring the results. We apologize for any trouble you've experienced.
Posted Oct 09, 2017 - 07:54 MDT