To view uptime history for your instance of Canvas, click here.

Users are unable to save edits made in ePortfolio
Incident Report for Instructure
Resolved
Our engineering team was able to identify the cause of the issue and deploy a resolution. Users should now be able to save content in ePortfolios. We apologize for the inconvenience and thank you for your patience.
Posted Jun 07, 2017 - 11:44 MDT
Identified
Starting on 6/3 users in Canvas started reporting issues with saving content in ePortfolios after editing. This is still an ongoing issue with which our engineers are working to resolve. We appreciate your patience.
Posted Jun 06, 2017 - 17:15 MDT