To view uptime history for your instance of Canvas, click here.

Users at some Canvas institutions experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Canvas performance is back to normal for the affected users. Please submit a request to Canvas Support if you notice any more slowness or timeouts.
Posted Apr 27, 2015 - 14:46 MDT
Investigating
A small percentage of Canvas users are currently experiencing slowness in the application. These users are sometimes experiencing slow page loads; sometimes, page loads are failing entirely. Our Operations team is looking into this. We apologize for any trouble.
Posted Apr 27, 2015 - 14:29 MDT