To view uptime history for your instance of Canvas, click here.

Document Preview Intermittent Error
Incident Report for Instructure
Resolved
The issue that was affecting some Canvas users' ability to preview documents in Canvas should now be resolved. Thank you for your patience.
Posted Nov 02, 2016 - 14:12 MDT
Monitoring
The issue has been reported to our partner company Box and they are investigating. We will continue to provide updates as we receive them.
Posted Nov 02, 2016 - 12:22 MDT
Identified
We are continuing to work with our partner company to resolve the Document Preview errors being experienced by some Canvas users. We will continue to post updates on this issue until resolution. Thank you for your patience.
Posted Nov 02, 2016 - 10:47 MDT
Investigating
Our team is currently investigating an intermittent issue affecting certain Canvas users' ability to preview documents. We're working with our partner company to resolve this issue as soon as possible and apologize for any inconvenience this may cause.
Posted Nov 02, 2016 - 10:15 MDT