To view uptime history for your instance of Canvas, click here.

Some users experienced slowness and error messages in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has restored access to Canvas for users who were seeing error messages. Performance for those experiencing slowness should also be back to normal now. We apologize for the disruption!
Posted May 06, 2015 - 11:47 MDT
Identified
Users at a few institutions are seeing slowness and error messages in the Canvas user interface currently. Our DevOps team is addressing the problem; we'll provide an update in about 15 minutes.
Posted May 06, 2015 - 11:23 MDT