To view uptime history for your instance of Canvas, click here.

Extended processing time on certain Canvas imports and exports
Incident Report for Instructure
Resolved
Performance is back to normal for import / export jobs for the schools that were affected by jobs slowness earlier. Thanks again for your patience as we made adjustments to bring this function back up to speed.
Posted Oct 21, 2014 - 15:43 MDT
Update
Performance on jobs for the affected institutions is improving steadily. The parameter changes devops made earlier seem to be working; it'll take a little time to work through the backlog and return performance to normal for newly-submitted import / export requests.
Posted Oct 21, 2014 - 14:33 MDT
Update
We're seeing somewhat improved jobs performance for affected institutions. Our devops team continues to work on this. Thanks for your continued patience.
Posted Oct 21, 2014 - 14:07 MDT
Update
We're pushing a configuration change now that should improve jobs performance. We'll continue to monitor this and provide updates.
Posted Oct 21, 2014 - 13:21 MDT
Monitoring
Some users are currently seeing extended processing time on certain jobs (e.g. SIS imports, course imports / exports). Our devops team is updating some configuration parameters and adding more resources to process jobs like these; we anticipate you'll see improved performance soon. Thanks for your patience!
Posted Oct 21, 2014 - 13:09 MDT