To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness in Canvas again
Incident Report for Instructure
Resolved
Our DevOps team has addressed the issue causing slowness for a small group of Canvas users this morning. Performance is back to normal. We sincerely apologize for the extended period of poor performance these users experienced. We will send an incident report to admins at affected schools by the end of the business day tomorrow (Tuesday).
Posted Feb 02, 2015 - 11:31 MST
Update
We're still investigating the cause of the slowness affecting a small group of Canvas users currently. We will report back again in 15 minutes; sorry for the ongoing trouble.
Posted Feb 02, 2015 - 11:15 MST
Update
Our DevOps team continues to investigate the slowness affecting a small percentage of Canvas users currently. We will provide another update in 15 minutes.
Posted Feb 02, 2015 - 10:52 MST
Investigating
The same group of users that was experiencing slowness in Canvas earlier is seeing a similar issue again. Our DevOps team is investigating the problem; we'll provide an update in 15 minutes.
Posted Feb 02, 2015 - 10:40 MST