To view uptime history for your instance of Canvas, click here.

Slow Load Times for Roll Call Attendance
Incident Report for Instructure
Resolved
Our Operations team has identified the issue causing slow load times for the Roll Call Attendance tool. Normal performance was restored at 11:22 am MT. Please contact Canvas Support if you continue to have any trouble loading the tool. Thanks!
Posted Apr 28, 2015 - 11:38 MDT
Investigating
The Roll Call Attendance tool is currently exhibiting slow load times and sometimes resulting in timeout errors. Our Operations team is currently investigating the issue. We will provide an update as soon as possible.
Posted Apr 28, 2015 - 10:20 MDT