To view uptime history for your instance of Canvas, click here.

Crocodoc document rendering failing intermittently for some users
Incident Report for Instructure
Resolved
Box has updated their status page at status.box.com and indicates that the Crocodoc service is officially running normally once again. Everything looks to be loading as it should when viewing documents in Canvas. We'll continue to monitor the service and let you know if we detect any further problems.
Posted Dec 14, 2015 - 09:43 MST
Investigating
Some Canvas users are seeing documents loading slowly or not at all in the Speedgrader and other places in Canvas where Crocodoc is used to generate the previews. We're working with our partners at Crocodoc to investigate. In the meantime, users can download documents to view them. We'll provide an update in 30 minutes. You can also track their progress on the Box status page here: status.box.com.
Posted Dec 14, 2015 - 09:35 MST