To view uptime history for your instance of Canvas, click here.

A very small number of users are seeing slowness and page errors
Incident Report for Instructure
Resolved
Our Operations team was able find the cause of the intermittent page errors and Slowness. All Canvas instances are now fully operational.
Posted May 13, 2016 - 12:33 MDT
Update
We are still investigating performance slowness and intermittent page errors, when accessing Canvas, with a small number of users.
Posted May 13, 2016 - 12:15 MDT
Investigating
We are currently looking into degraded performance for a very small group of users, who are seeing slowness and intermittent page errors.
Posted May 13, 2016 - 11:43 MDT