To view uptime history for your instance of Canvas, click here.

Import Slowness
Incident Report for Instructure
Resolved
Our operations team has resolved the issue and job server performance has returned to normal. We apologize for any inconvenience this has caused.
Posted Oct 31, 2016 - 11:50 MDT
Monitoring
Our job servers are beginning to clear out the previously queued imports. We anticipate the imports should return to normal operation shortly.
Posted Oct 31, 2016 - 11:24 MDT
Investigating
We are currently experiencing some slowness on a very small portion of Canvas uploads. This includes Course imports and Gradebook imports. We are investigating why this is happening and will provide updates as more details become available.
Posted Oct 31, 2016 - 10:10 MDT