To view uptime history for your instance of Canvas, click here.

A small subset of UK based users are experiencing slowness or page errors when accessing Canvas
Incident Report for Instructure
Resolved
A small percentage of Canvas users in the UK were experiencing page errors when accessing Canvas between 11:34 - 12:34 BST. Our DevOps team has ensured the site is available and running normally now. We apologize for any trouble you've experienced.
Posted Oct 09, 2017 - 05:54 MDT
Investigating
A small percentage of Canvas users in the UK are experiencing page errors when accessing Canvas. Our DevOps team is working to resolve this issue. We apologize for any trouble you've experienced
Posted Oct 09, 2017 - 05:16 MDT