To view uptime history for your instance of Canvas, click here.

Users at a small percentage of Canvas institutions experiencing slowness
Incident Report for Instructure
Resolved
Our DevOps team identified the source of the slowness affecting some Canvas users over the last 10-15 minutes and has resolved the problem. Canvas should now be performing normally again for all users. The issue we located and resolved affected the function that allows Canvas to auto-scale, adding more resources as demand increases over the course of a given day. We apologize for the trouble!
Posted Jul 29, 2015 - 09:58 MDT
Investigating
Users at a small percentage of Canvas institutions are experiencing slowness in the app currently. Your institution is affected, and our DevOps team is looking into the issue.

We apologize for the trouble, and we'll provide an update in about 15 minutes.
Posted Jul 29, 2015 - 09:44 MDT