To view uptime history for your instance of Canvas, click here.

Intermittent Error when Previewing documents in Speedgrader
Incident Report for Instructure
Resolved
Since our last update, we've continued to see lower frequency of errors, including no new reports of the 'Service is Unavailable' error message, in the last 24 hours. Our Engineering team has made a few changes to how timeouts like this are reported and handled by automatic processes in Canvas. This will allow for quicker identification of errors that occur, and enable us to contact our partner companies for faster resolution.
Posted Nov 18, 2016 - 18:43 MST
Update
Our Engineering team continues to work with our partner company in order to find a solution to the 'Service is Unavailable' error message, when previewing documents in Speedgrader. As additional data is gathered, we're beginning to see a lower frequency of the error occurring, and we'll continue to work towards a solution. Thank you for your patience during this time.
Posted Nov 17, 2016 - 23:08 MST
Investigating
Some users are reporting a 'Service is Unavailable' error message when previewing documents in Speedgrader. We have identified an issue that intermittently causes a connection timeout between Canvas and the Crocodoc document previewer. We are continuing to work with our partner company to ensure this is addressed. We apologize for the situation and appreciate your patience.
Posted Nov 16, 2016 - 11:46 MST