To view uptime history for your instance of Canvas, click here.

Some users are experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Canvas performance is back to normal for the affected Canvas sites. Please submit a request to Canvas Support if you notice any more slowness issues. We apologize for any inconvenience this may have caused.
Posted May 14, 2015 - 18:36 MDT
Investigating
Some of your users are experiencing slowness when they try to access Canvas as of 5:55 PM Mountain Time. Our Operations team is working on this issue; we'll provide more information in 15 minutes.
Posted May 14, 2015 - 18:16 MDT