To view uptime history for your instance of Canvas, click here.

Some Institutions Unable to Access Canvas
Incident Report for Instructure
Resolved
From 4:38 pm MDT to 4:59pm MDT, some institutions reported seeing a 'Page Error' when trying to access their Canvas instance. Our DevOps team was able to quickly identify and resolve the cause of these page errors. We apologize for any inconvenience this may have caused.
Posted Aug 15, 2017 - 17:07 MDT
Investigating
Some Institutions have reported seeing a 'Page Error' when trying to access their Canvas instance. Our DevOps team is currently investigating the cause of these page errors. We will post updates as they become available. We apologize for any inconvenience this may be causing.
Posted Aug 15, 2017 - 16:56 MDT