To view uptime history for your instance of Canvas, click here.

Users are currently unable to access and use Canvas
Incident Report for Instructure
Resolved
Performance has remained stable and users are accessing and using Canvas as normal. We consider this incident to be resolved.
Posted Mar 10, 2016 - 02:28 MST
Update
Things have remained stable since our last update. We're continuing to monitor performance and we're working closely with our partners at Amazon. We'll provide updates as we have them.
Posted Mar 10, 2016 - 02:09 MST
Monitoring
We're no longer seeing problems with AWS, but will continue to monitor and update if the situation changes.
Posted Mar 10, 2016 - 01:55 MST
Update
Our Operations team has discovered that the problem lies at the AWS service layer that we are attempting to work around. For reference, their status page is status.aws.amazon.com. We'll continue to provide updates here as we make progress.
Posted Mar 10, 2016 - 01:42 MST
Identified
At this time, we're seeing that other users appear to be affected. We'll continue to dig in on this and update again in 15 minutes.
Posted Mar 10, 2016 - 01:35 MST
Monitoring
Our Operations team believes they've corrected the issue and we're seeing some successful page loads again. We'll continue to monitor and report back in 15 minutes or less.
Posted Mar 10, 2016 - 01:26 MST
Identified
Our Operations team has identified the cause of the issue and is hard at work implementing a solution. We apologize for the inconvenience and will provide another update soon.
Posted Mar 10, 2016 - 01:19 MST
Investigating
Our Operations team is currently investigating an issue that's preventing users from accessing or using Canvas. When users attempt to load the site, they're presented with a white page. We'll provide another update in 15 minutes or less.
Posted Mar 10, 2016 - 01:11 MST