To view uptime history for your instance of Canvas, click here.

Scattered Intermittent Performance Issues for U.S. Customers
Incident Report for Instructure
Resolved
A fix has been deployed for the slowness and errors users have been seeing today. Canvas is loading normally once again. We're sorry for any trouble you may have experienced with this issue today.
Posted Sep 12, 2017 - 16:32 MDT
Update
Some institutions may be seeing prolonged periods of slowness and timeout errors. Our DevOps team continues their work on a fix, though it may still take some time for that fix to be complete. We will let you know once we have more information.
Posted Sep 12, 2017 - 14:29 MDT
Identified
Canvas users in the U.S. may be experiencing scattered intermittent slowness and timeout errors. These issues are happening for short periods of time across various accounts. Our DevOps team has identified the cause and is working on a fix. We'll post an update here as soon as it is available.
Posted Sep 12, 2017 - 11:20 MDT