To view uptime history for your instance of Canvas, click here.

Clients using the new Canvas SIS Integration Platform to sync enrollment data to Canvas seeing delays in syncing
Incident Report for Instructure
Resolved
Here’s an update on our work to improve performance of the Canvas SIS integration platform:

- Migrating the platform’s databases to more capable hardware: This task is complete. We are testing performance to measure the impact this update will have on the platform’s ability to ingest and process data from PowerSchool.
- Updating the sync-management software: This task is still in progress. We expect our partner to deploy the update later tonight or tomorrow morning (Saturday).

Syncs between the platform and Canvas are still paused while we test and validate data. Thank you for your patience. We will provide another update by the end of the day tomorrow (Saturday). Because this incident affects only a small portion of the Canvas userbase, we will resolve the incident on the status page and communicate further updates by email to admins at the affected schools.
Posted Aug 18, 2017 - 23:38 MDT
Monitoring
Some Canvas customers are using our new SIS integration platform to pass data from their SIS to Canvas. Currently, this group comprises about 200 K12 customers that use the PowerSchool SIS. We have seen slow performance from the platform over the last three days. This has affected both of the platform’s key functions:

- Ingesting data from PowerSchool
- Synchronizing data to Canvas

The result of this slowness has been that changes the affected schools have made in PowerSchool have not appeared in Canvas in a timely way. We sincerely apologize for the trouble this has caused them and their users.

Our engineering team is working with the partner who provides the SIS integration platform, and they have identified two opportunities to significantly improve performance:

- We will migrate the platform’s databases to more capable hardware. This will help the platform ingest and process data from PowerSchool more quickly. The migration process is underway, and we anticipate it will be complete later today or tomorrow.
- We will optimize the software that manages data sync between the platform and Canvas. Our partner has developed a patch; it is now in QA. We expect they will deploy the patch today or tomorrow.

As part of these efforts, we paused SIS syncs through the platform at about 9:30 AM Mountain Time (11:30 AM Eastern Time, 8:30 AM Pacific Time) this morning. We will post update on these projects this afternoon. We’ll also let you know when we are able to resume syncs.
Posted Aug 18, 2017 - 11:42 MDT