To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness and timeouts when accessing Canvas
Incident Report for Instructure
Resolved
Performance has returned to normal. Users can access and use Canvas once again. We thank you for your patience and apologize for any inconvenience this may have caused.
Posted Aug 08, 2016 - 19:52 MDT
Monitoring
Our Operations team was able to quickly identify the cause of this behavior and has a solution in place. We'll continue to monitor the issue for some time to ensure that it's been completely resolved.
Posted Aug 08, 2016 - 19:49 MDT
Investigating
Our Operations team is currently investigating an issue affecting users as they attempt to load pages in Canvas. They are experiencing extreme slowness or timeouts/white pages. We'll provide another update in 15 minutes or less.
Posted Aug 08, 2016 - 19:42 MDT