To view uptime history for your instance of Canvas, click here.

Canvas slowness affecting a small percentage of users.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 09, 2015 - 09:35 MDT
Investigating
A very small percentage of Canvas users experienced slowness between about 9:27 AM MT and 9:31 AM MT, and may have also encountered page errors. Our DevOps team has resolved the problem. We apologize for any inconvenience caused for affected users at that time.
Posted Mar 09, 2015 - 09:35 MDT