To view uptime history for your instance of Canvas, click here.

Interruptions to Mastery Paths
Incident Report for Instructure
Resolved
The latency has been resolved with Mastery Paths. We sincerely apologize for any inconvenience this might have caused you, and appreciate your patience during this situation.
Posted Apr 10, 2017 - 22:20 MDT
Monitoring
We're continuing to work with Amazon Web Services to resolve the latency that some users are experiencing with Mastery Paths. We do not yet have any timeframe of when these delays are expected to be resolved. We will post another update once we have a forthcoming resolution. Thank you again for your patience.
Posted Apr 10, 2017 - 21:52 MDT
Identified
Our engineers are continuing to work with Amazon Web Services (AWS) on a full resolution. Currently they're processing the accumulated requests, but we do not have an estimated time frame for a fix at this time. Users may continue to experience latency issues for now. We will post another update in the next 30 minutes, thank you.
Posted Apr 10, 2017 - 21:23 MDT
Investigating
Due to increased API error rates at Amazon Web Services (AWS), some functionality, such as Mastery Paths, may experience significant delays in processing. This issue only impacts a small minority of functionality within Canvas, but when users are running into this, there will be noticeable delays/slowness. We are currently working with AWS engineers for a resolution. We will post another update within 30 minutes. We appreciate your patience and apologize for this situation.
Posted Apr 10, 2017 - 20:41 MDT