To view uptime history for your instance of Canvas, click here.

A small percentage of Canvas users are experiencing slowness
Incident Report for Instructure
Resolved
All users should now be able to access and use Canvas as usual. We sincerely apologize for the brief time of slowness.
Posted May 02, 2016 - 14:30 MDT
Investigating
Starting at 19:30 UTC we have received notification of some users experiencing slowness. We apologize for any disruption this may be causing. We will continue to investigate and provide updates, as they are available.
Posted May 02, 2016 - 13:30 MDT