Some users unable to access Canvas
Incident Report for Canvas
Resolved
This incident has been resolved. We appreciate your patience, and apologize for any inconvenience this may have caused.
Posted 6 months ago. May 02, 2017 - 11:18 MDT
Investigating
A small percentage of Canvas users are currently unable to access Canvas. Our Operations team is looking into the issue now. We will provide an update as soon as we have more information.
Posted 6 months ago. May 02, 2017 - 11:12 MDT